
International Journal of Research Publication and ReviewsVol (2)  Issue (7) (2021) Page 533-543 

 

International Journal of Research Publication and Reviews 

 

Journal homepage: www.ijrpr.com  ISSN 2582-7421 

 
 

COMPARATIVE ANALYSIS OF  AUTOMATED TOLL COLLECTION SYSTEM 

V.Nithish Bharadwaz
1
,N.Sri Vidya

2
 ,S.Kireeti

3
,Dr.S N Chandra Shekhar

4
 

1,2,3
ECE, Sreenidhi Institute of Science and Technology, Ghatkesar, Hyderabad 

4
Assistant Professor, ECE, Sreenidhi Institute of Science and Technology, Ghatkesar, Hyderabad 

 

ABSTRACT 

:Automated Toll Collection System used for amassing tax robotically. In this we do the identity with the assist of radio frequency. A car will preserve an RFID 

tag. This tag is not anything however specific identity range assigned. This could be assigned with the aid of using RTO or site visitors governing authority. In 

accordance with this range we can store, all simple records in addition to the quantity he has paid earlier for the TOLL series. Reader could be strategically 

positioned at toll series middle. Whenever the car passes the toll series middle, the tax quantity could be deducted from his pay as you go stability. New stability 

could be up to date. In case if one has inadequate stability, his up to date stability could be terrible one. To address this problem, we're alarming a sound, with a 

purpose to alert the authority that this car doesn‟t have enough stability and that specific car may be trapped. As cars don‟t need to forestall in a queue, it assures 

time saving, gasoline conservation and additionally contributing in saving of money. Automatic Toll Collection structures have clearly helped lots in decreasing 

the heavy congestion brought on withinside the metropolitan towns of today. It is one of the simplest techniques used to prepare the heavy waft of site visitors.  

 

I.  INTRODUCTION  

As all of us recognize that transportation is the spine of any country‟s economy. Improvement in transportation structures end result into the best way of 

life wherein we gain notable freedom for movement, sizeable alternate in synthetic items and services, in addition to better fee of employment tiers and 

social mobility. In fact, the financial circumstance of a country has been intently associated with green approaches of transportation. Increasing range of 

cars at the road, end result into range of issues which include congestion, twist of fate fee, air pollutants and plenty of different . All financial sports for 

one-of-a-kind responsibilities use one-of-a-kind techniques of transportation. For this reason, growing transportation is a direct effect on productiveness 

of country and the economy. Reducing the fee of transporting aid at manufacturing webweb sites and delivery finished items to markets is one of the 

crucial key elements in financial competition. Automatic toll series is a era lets in the automatic digital series of toll prices. As it's miles studied with the 

aid of using researchers and additionally carried out in diverse expressways, bridges, and tunnels require this sort of procedure of Automatic Toll Plaza. 

ATP is able to figuring out if the car is registered or now no longer, after which informing the control middle approximately to procedure violations, 

debits, and collaborating accounts .The maximum splendid gain of this ATP machine is that it's miles able to dispose of congestion in toll plaza, 

specifically in the course of the ones seasons while site visitors appears to be better than normal. 

 

II.LITERATURE REVIEW  

A range of associated works exist in literature, utility of RFID Technology to one-of-a-kind regions and especially to the location of instructional 

attendance tracking problem. In [6], authors designed and carried out a version of a secured and transportable embedded reader machine to study the 

biometric information from the digital passport. The authors tried to clear up issues of reliability, safety and privateness in E-passports with the aid of 

using authenticating holder on-line the use of Global System of Mobile Communications (GSM) community. The GSM community is the principle 

interface among identity centre and the epassport reader. The verbal exchange information is included among server and e-passport reader with the aid 

of using the use of AES to encrypt information for safety whilst moving thru GSM community. Author in [5] reviewed the contemporary studies utility 

of RFID to one-of-a-kind regions with emphasis on utility for deliver chain control and advanced a taxonomic framework to categorise li terature which 

permits speedy and smooth content material evaluation to assist perceive regions for destiny studies. Authors in [9] reviewed using RFID in an 

integratedcircuit(IC) packaging residence to remedy stock transaction issues. His examine indicates that RFID contributes sizable upgrades to the water 

receiving procedure and the stock transaction procedure that lessen labour fee and man-made errors. In [10], an automatic attendance control machine 

changed into carried out each in digital and cell platform the use of desk bound matrix AR four hundred RFID reader with 4 circulatory polarized 

antennae and Symbol MC9000-G hand-held RFID reader respectively. In the digital platform, the attendance control machine 
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III.PRICIPLE 

When a rectangular coil carrying current is placed in a magnetic field, a torque acts on the coil which rotates it continuously.When the coil rotates, the 

shaft attached to it also rotates and thus it is able to do mechanical work.Every DC motor has six basic parts -- axle, rotor (a.k.a., armature), stator, 

commutator, field magnet(s), and brushes. In most common DC motors (and all that BEAMers will see), the external magnetic field is produced by 

high-strength permanent magnets
1
. The stator is the stationary part of the motor -- this includes the motor casing, as well as two or more permanent 

magnet pole pieces. The rotor (together with the axle and attached commutator) rotate with respect to the stator. The rotor consists of windings 

(generally on a core), the windings being electrically connected to the commutator. The above diagram shows a common motor la yout -- with the rotor 

inside the stator (field) magnets. 

The geometry of the brushes, commentator contacts, and rotor windings are such that when power is applied, the polarities of the energized winding 

and the stator magnet(s) are misaligned, and the rotor will rotate until it is almost aligned with the stator's field magnets. As the rotor reaches alignment, 

the brushes move to the next commentator contacts, and energize the next winding. Given our example two-pole motor, the rotation reverses the 

direction of current through the rotor winding, leading to a "flip" of the rotor's magnetic field, driving it to continue rotating. 

In real life, though, DC motors will always have more than two poles (three is a very common number). In particular, this avoids "dead spots" in the 

commutator. You can imagine how with our example two-pole motor, if the rotor is exactly at the middle of its rotation (perfectly aligned with the field 

magnets), it will get "stuck" there. Meanwhile, with a two-pole motor, there is a moment where the commutator shorts out the power supply (i.e., both 

brushes touch both commutator contacts simultaneously). This would be bad for the power supply, waste energy, and damage motor components as 

well. Yet another disadvantage of such a simple motor is that it would exhibit a high amount of torque"ripple" (the amount of torque it could produce is 

cyclic with the position of the rotor). 

 

 

 

IV.WORKING 

 

Parts of a DC Motor 

Armature 

A D.C. motor includes a square coil fabricated from insulated copper cord wound on a gentle iron center. This coil wound at the gentle iron center 

paperwork the armature. The coil is hooked up on an axle and is positioned among the cylindrical concave poles of a magnet.  

Commutator 

A commutator is used to opposite the path of waft of contemporary. Commutator is a copper ring break up into  elements C1 and C2. The break up 

earrings are insulated shape every different and hooked up at the axle of the motor. The  ends of the coil are soldered to those earrings. They rotate at 

the side of the coil. Commutator earrings are related to a battery. The wires from the battery aren't related to the earrings however to the brushes which 

can be in touch with the earrings. 

http://encyclobeamia.solarbotics.net/articles/dc.html
http://encyclobeamia.solarbotics.net/articles/beam.html
http://encyclobeamia.solarbotics.net/articles/current.html
http://encyclobeamia.solarbotics.net/articles/dc.html
http://encyclobeamia.solarbotics.net/articles/torque.html
http://encyclobeamia.solarbotics.net/articles/torque.html


535 International Journal of Research Publication and Reviews Vol (2)  Issue (7) (2021) Page 533-543 

 

 

 

Brushes 

Two small strips of carbon, referred to as brushes press barely towards the 2 break up earrings, and the break up earrings rotate among the brushes. 

The carbon brushes are related to a D.C. supply. 

 

Working of a DC Motor 

When the coil is powered, a magnetic area is generated across the armature. The left aspect of the armature is driven farfar  from the left magnet and 

drawn closer to the right, inflicting rotation. 

 

 

 

When the coil turns thru 900, the brushes lose touch with the commutator and the contemporary stops flowing thru the coil.  

However the coil continues turning due to its personal momentum.  

Now while the coil turns thru 1800, the edges get interchanged. As a end result the commutator ring C1 is now in touch with brush B2 and commutator 

ring C2 is in touch with brush B1. Therefore, the contemporary maintains to waft withinside the identical path. 
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PARAMETRS OF THE DC MOTRS 

1. Direction of rotation 

2. Motor Speed 

3. Motor Torque 

4. Motor Start and Stop 

5. Direction of Rotation 

A DC Motor has  wires. We can name them the tremendous terminal and the terrible terminal, even though those are quite lots arbitrary names (not like 

a battery wherein those polarities are crucial and now no longer to be mixed!). On a motor, we are saying that once the + cord is hooked up to + 

terminal on a electricity supply, and the - cord is hooked up to the - terminal supply at the identical electricity supply, the motor rotates clockwise (in 

case you are searching closer to the motor shaft). If you opposite the cord polarities in order that every cord is hooked up to the opposing electricity 

deliver terminal, then the motor rotates counter clockwise. Notice that is simply an arbitrary choice and that a few motor producers ought to without 

difficulty pick out the opposing convention. As lengthy as you recognize what rotation you get with one polarity, you could continually join in this sort 

of style which you get the path which you need on a in keeping with polarity basis. 

 

 

 

DC Motor Rotation vs Polarity 

Facts: 

DC Motor rotation has not anything to do with the voltage importance or the contemporary importance flowing thru the motor. 

DC Motor rotation does need to do with the voltage polarity and the path of the contemporary waft. 

 

 

DC Motor Speed 

Whereas the voltage polarity controls DC motor rotation, voltage importance controls motor velocity. Think of the voltage carried out as a facilitator 

for the strengthening of the magnetic area. In different words, the better the voltage, the faster will the magnetic area become strong. Remember that a 

DC motor has an electromagnet and a chain of everlasting magnets. The carried out voltage generates a magnetic area at the electromagnet portion. This 

electromagnet area is made to oppose the everlasting magnet area. If the electromagnet area could be very strong, then each magnetic entities will try 
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and repel every different from one aspect, in addition to atract every different from the alternative aspect. The more potent the brought on magnetic 

area, the faster will this separation/attaction will try and take place. As a end result, motor velocity is without delay proportional to carried out voltage. 

 

 

Motor Speed Curve 

 One component to have in thoughts is that the motor velocity isn't always completely lineal. Each motor could have their personal voltage/velocity 

curve. One aspect I can assure from every motor is that at very low voltages, the motor will sincerely now no longer circulate. This is due to the fact the 

magnetic area electricity isn't always sufficient to conquer friction. Once friction is overcome, motor velocity will begin to growth as voltage growth.  

The following video suggests the idea of velocity manipulate and gives a few thoughts on how this could be achieved.  

  Motor Torque 

In the preceding phase I form of defined velocity as having to do with the electricity of the magnetic area, however that is in fact misleading. Speed has 

to do with how speedy the magnetic area is constructed and the attraction/repel forces are set up into the 2 magnetic structures. Motor electricity, on the 

alternative hand, has to do with magnetic area electricity. The more potent the electromagnet draws the everlasting magnet, the extra pressure is exerted 

at the motor load. 

Per instance, believe a motor looking to carry 10 kilos of weight. This is a pressure that once improved with the aid of using a distance (how lots from 

the floor we're lifting the load) consequences in WORK. This WORK while exerted thru a predetermined quantity of time (for the way lengthy we're 

lifting the weight) offers us electricity. But some thing electricity got here in, need to pop out as power cannot be created or destroyed. So which you 

recognize, the electricity that we're presenting to the motor is computed with the aid of using 

P = IV 

Where P is electricity, I is motor contemporary and V is motor voltage 

Hence, if the voltage (motor velocity) is maintained constant, how lots load we're shifting need to come from the contemporary. As you growth load (or 

torque requirements) contemporary need to additionally growth. 

.  

 

Motor Loading 

One component approximately DC vehicles which we need to now no longer neglect about is that loading or growth of torque cannot be endless as 

there's a factor wherein the motor sincerely cannot circulate. When this happens, we name this loading “Stalling Torque”. At the identical time that is 

the most quantity of contemporary the motor will see, and it's miles check with Stalling Current. Stalling merits a complete bankruptcy as that is a 

completely crucial state of affairs with a purpose to outline a incredible deal of the controller to be used. I promise I will later write a put up on stalling 

and its intricacies. 

 

 



International Journal of Research Publication and Reviews Vol (2)  Issue (7) (2021) Page 533-543                                                    538 

 

 

V.SIMULATION RESULT 

PROGRAMMING ARDUINO 

Once arduino IDE is set up at the pc, join the board with pc the use of USB cable. Now open the arduino IDE and pick out the appropriate board with 

the aid of using choosing Tools>Boards>Arduino/Genuino Uno, and pick out the appropriate Port with the aid of using choosing Tools>Port. Arduino 

Uno is programmed the use of Arduino programming language primarily based totally on Wiring. To get it commenced with Arduino Uno board and 

blink the integrated LED, load the instance code with the aid of using choosing Files>Examples>Basics>Blink. Once the instance code (additionally 

proven below) is loaded into your IDE, click on at the „add‟ button given at the pinnacle bar. Once the add is finished, you have to see the Arduino‟s 

integrated LED blinking.  Below is the instance code for blinking: 

 

ARDUINO – INSTALLATION 

After studying approximately the principle elements of the Arduino UNO board, we're prepared to discover ways to installation the Arduino IDE. Once 

we study this, we can be prepared to add our application at the Arduino board.     

In this section, we can study in smooth steps, a way to installation the Arduino IDE on our pc and put together the board to acquire this system thru 

USB cable.  

Step 1: First you need to have your Arduino board (you could pick out your preferred board) and a USB cable. In case you operate Arduino UNO, 

Arduino Duemilanove, Nano, Arduino Mega 2560, or Diecimila, you may want a fashionable USB cable (A plug to B plug), the type you will connect 

with a USB printer as proven withinside the following image. 

 

 

In case you operate Arduino Nano, you may want an A to Mini-B cable alternatively as proven withinside the following image 

 

 

 

 

Step 2:  Download Arduino IDE Software.   

You can get one-of-a-kind variations of Arduino IDE from the Download web page at the Arduino Official website. You need to pick your software 

program, that is like minded together along with your running machine (Windows, IOS, or Linux). After your document down load is complete, unzip 

the document. 
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Step 3: Power up your board.   

The Arduino Uno, Mega, Duemilanove and Arduino Nano robotically draw electricity from either, the USB connection to the pc or an outside 

electricity deliver. If you're the use of an Arduino Diecimila, you need to ensure that the board is configured to attract electricity from the USB 

connection. The electricity supply is chosen with a jumper, a small piece of plastic that suits onto  of the 3 pins among the USB and electricity jacks. 

Check that it's miles on the 2 pins closest to the USB port.   

Connect the Arduino board on your pc the use of the USB cable. The inexperienced electricity LED (classified PWR) have to glow. 

 

Step 4: Launch Arduino IDE.   

After your Arduino IDE software program is downloaded, you want to unzip the folder. Inside the folder, you could discover the utility icon with an 

infinity label (utility.exe). Doubleclick the icon to begin the IDE 

 

 

 

Step 5: Open your first task.    

Once the software program starts, you've got got  options:  

1. Create a brand new task.   

2. Open an present task instance.   

To create a brand new task, pick File --> New 
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To open an present task instance, pick File -> Example -> Basics -> Blink. 

 

 

Here, we're choosing simply one of the examples with the call Blink. It turns the LED on and stale with a while delay. You can pick another instance 

from the list.  

Step 6: Select your Arduino board.     

To keep away from any blunders whilst importing your application to the board, you need to pick the appropriate Arduino board call, which fits with 

the board related on your pc.   
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Here, we've got decided on Arduino Uno board in line with our tutorial, however you need to pick the call matching the board which you are the use of.  

 

Step 7: Select your serial port.   

Select the serial tool of the Arduino board. Go to Tools -> Serial Port menu. This is in all likelihood to be COM3 or better (COM1 and COM2 are 

generally reserved for hardware serial ports). To discover out, you could disconnect your Arduino board and re-open the menu, the access that 

disappears have to be of the Arduino board. Reconnect the board and pick that serial port. 

 

 

 

Step 8: Upload the program to your board.   

 

Before explaining how we can upload our program to the board, we must demonstrate the function of each symbol appearing in the Arduino IDE 

toolbar 
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A- Used to test if there's any compilation blunders.   

B- Used to add a application to the Arduino board.  

C- Shortcut used to create a brand new caricature.   

D- Used to without delay open one in all the instance caricature.  

E- Used to store your caricature.   

F- Serial reveal used to acquire serial information from the board and ship the serial information to the board.   

Now, sincerely click on the "Upload" button withinside the surroundings. Wait some seconds; you may see the RX and TX LEDs at  the board, flashing. 

If the add is successful, the message "Done importing" will seem withinside the fame bar.   

Note: If you've got got an Arduino Mini, NG, or different board, you want to press the reset button bodily at the board, right now earlier than clicking 

the add button at the Arduino Software. 

 

ARDUINO – PROGRAM STRUCTURE 

we can examine in depth, the Arduino application shape and we can study extra new terminologies used withinside the Arduino world. The Arduino 

software program is open-supply. The supply code for the Java surroundings is launched below the GPL and the C/C++ microcontroller libraries are 

below the LGPL.  

Sketch:  The first new terminology is the Arduino application referred to as “caricature”.  

Structure Arduino packages may be divided in 3 important elements: Structure, Values (variables and constants), and Functions. In this tutorial, we can 

study the Arduino software program application, step with the aid of using step, and the way we are able to write this system with none syntax or 

compilation blunders.  

Let us begin with the Structure. Software shape encompass  important functions:  

 Setup( ) characteristic 

 Loop( ) characteristic 
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 PURPOSE: The setup() characteristic is referred to as while a caricature starts. Use it to initialize the variables, pin modes, begin the use of libraries, 

etc. The setup characteristic will handiest run once, after every electricity up or reset of the Arduino board.  

INPUT:      -  

OUTPUT:      -  

 RETURN:      

 

 

PURPOSE: After growing a setup() characteristic, which initializes and units the preliminary values, the loop() characteristic does exactly what its call 

indicates, and loops consecutively, permitting your application to trade and respond. Use it to actively manipulate the Arduino board.  

INPUT:      -  

OUTPUT:     -  

 RETURN: 

 

VI. CONCLUSION AND FUTURE WORK  

 

The Electronic Toll Collection machine in limited-access highway primarily based totally on RFID, a layout scheme changed into positioned forward. It 

is low fee, excessive safety, a long way verbal exchange and efficiency, etc. It now no longer handiest improves the passage cappotential of limited-

access highway however additionally improves the era degree of charge. Electronic toll series machine the use of RFID is an powerful degree to lessen 

control prices and fees, on the identical time, substantially lessen noise and pollutant emission of toll station. In the layout of the proposed Electronic 

toll series (ETC) machine, actual time toll series and anti-robbery answer machine were designed. This reduces the guide labour and delays that 

regularly arise on roads. This machine of amassing tolls is eco pleasant and additionally consequences in extended toll lane capacity. Also an anti-

robbery answer machine module which prevents passing of any defaulter car is carried out, consequently assuring safety at the roadways. 
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